Intoxalockcausing engine problems

J Review updated:

I recently had the Intoxalock system installed in my 1999 Mercury Grand Marquis. My car ran fine until about a week after having it installed. First, it drained my battery because I was waiting for the state to issue my limited license. I decided that was my fault as I had it installed too soon. So I bought a new battery, but then my car started to run horribly. The engine was missing, my check engine light came on, and I was worried about getting home from work. I took it to the dealer that installed my Intoxalock (AMPT in Kasson, MN) and had them run diagnostics. They told me cylinders three and five were not firing properly, so I replaced my plugs and wires but to no avail. It still ran horribly. So I bought a new car, a 2004 Ford Taurus. I had AMPT move my interlock device to the Taurus and it ran fine for almost two weeks. And then the Taurus also had the engine light come on. I brought it to the dealer I got my car from, (Lowell's Auto in Dodge Center, MN) and after he hooked up his diagnostic machine I was told that the engine was misfiring on cylinder three. So I replaced the coil pack on that car, and it still is not helping. I can not afford to keep replacing parts, but I also can't run my car without an ignition device. It is very frustrating. My problem is I am not sure if it is the device, or the person that installed it. I would like to know if others have experienced my problem with this device or if it is maybe an error on the part of the installer? Either way, I am thinking I would like a different one installed as the current installer is the only one in the area that does Intoxalock. Is there a way to switch providers? I am pretty sure I am locked into a year contract with them though?

Responses

  • Li
    Life mistakes Sep 26, 2018
    This comment was posted by
    a verified customer
    Verified customer

    Definitely go with another vendor intoxalock is known for messing up vehicles that is there #1 issue. It’s not the techs it’s the device itself.

    1 Votes
  • Ju
    jusluvit Oct 12, 2018

    Wow I'am so happy that you wrote this, Believe it or not I just went thru the same thing exactly, with my 1998 Ford Explorer Sport in Phoenix Az. it has been bothering me alot because I do take care of my SUV. I figure being single I have to have a reliable ride. And since my interlock my truck has been missing and running like shit. Changed oil, filter, plugs, wires, and still got check engine light on. i would talk about to a couple friends and they would say "I don't think that a interlock from the court would be able to mess up your vehicle or they would have a ton of complaints" I think the court doesn't even hear any thing about it because if someone did think it was the interlock they would question the interlock place . I did and he said " i really don't think it's because of the interlock and it is a 1998" anyway i signed the papers to put it on, reread those and they are not responsible for any thing that goes wrong with your ride only the interlock it self.
    I understand I got my DUI and I am doing everything they ask, which is alot and alot of money, now even more to fix my SUV. but Thanks again because I thought it had to have something to do with the interlock, so because you had the same trouble it means "I am not Crazy"
    I just wish we could find out if others are having the same problem. Wishful thinking but maybe they would have to recall them.
    You Have A Great Day! Kat

    2 Votes
  • Ja
    james1957x Oct 23, 2018
    This comment was posted by
    a verified customer
    Verified customer

    same here, and electrical problems as well, they screwed my bmw up and will not accept any responsibility at all. crooked basterds

    2 Votes
  • Me
    Megan Molkentin Nov 26, 2018
    This comment was posted by
    a verified customer
    Verified customer

    These devise's are Shit! My truck was fine before IO put that thing in my truck. Check engine light on, I put Two New Batteries in my truck. I just brought it back from the shop because I had to have a new alternator put in. I have been watching my bills from them and they have charged me 3 times for lock outs that were not my fault. I went to a friends house in Downtown Milwaukee, everything was fine getting there and when I went to leave, my truck wouldn't start. The interlock wouldn't light up, NOTHING. This happened before so when I talked to them, this guy told me to unhook the device inside first, we tried that around 3 times and it still didn't work, so he told me to take the negative cable off my battery wait 15 mins, hook it back up then try it and it worked, but it threw me into re-calibration. That also happened when I was downtown. I took the cable off waited then it started. They charged me 150.00 for doing that because they said I didn't have a call into them. That's total B.S. I tried to call and sat on the phone for over an hour with no answer. When I called them on Monday mourning, they told me that they have someone on site 24 hours a day. Bull Shit.!! No one even called me back either when I left my number for them. I wasn't about to sit downtown all by myself waiting to get Mugged or Murdered waiting for them to say they would call and never did! They know they have us by the Balls because we have to have these in our cars. What are we supposed to do? These crooks are taking money from me left and right, and I am supposed to have this in my truck for 3 more years!!??!!! Fuck Them. They constantly are charging me for unnecessary things and I have been put in lock out countdown 16 times in 6 months, WTF ??? I know just because I am a female but this is about all I can take from intoxalock!! My truck is being ruined by this device and they don't care. The next time I see them take a penny that they don't deserve, I swear to God, I'm suing them!!!

    2 Votes
  • Me
    Megan Molkentin Nov 26, 2018
    This comment was posted by
    a verified customer
    Verified customer

    @Megan Molkentin Not to mention having to have my truck towed 6 times because of breaking down electrically. My truck is almost brand new and never had a problem until they got a hold of me.!! I'm looking for someone else right now. Make sure you write them a letter before you cancel them, , there's a fee for that too. Don't fart in your car, , , they will probably charge you for un-useable Gas!!

    1 Votes
  • Ma
    Max San Diego Jan 16, 2019

    @Megan Molkentin Hey Megan? Please see what I wrote below. I’m sorry your having the same issue as myself.

    1 Votes
  • Ma
    Max San Diego Jan 16, 2019

    I am having the IDENTICAL issue in my 2004 PT Cruiser. Literally a week after having the Intoxalock IID device put in, my check engine light has come on..we replaced spark plugs, wires, alternator, oxygen sensors etc etc and the car still hasn’t had the check engine light turn off. Multiple mechanics have said it must be the damn IID device messing with the computer. Just today, my car died on the freeway for the upteenth time and my mechanic said I now need an entirely new computer - that’s roughly $2, 000!! WTF?! I’m furious. Intoxalock are EXTREMELY rude and literally hang up on me when I try to speak with them.
    I want to figure out a way to approach this legally and/or in court. I am so beyond frustrated with them and their damn device causing problems that did not exist prior. Costing me money. EFF THEM!

    2 Votes
  • Mi
    Mister Riddick Apr 12, 2019
    This comment was posted by
    a verified customer
    Verified customer

    I agree! At first, it killed my battery and they told me its a safe mode switch on my device. Press and hold it for 3 sec and you will hear 5 beeps i think. I tried that and nothing happen. Called back and they told me "Oh it don't work for the state of NY" They told me i have to buy a new battery. My battery was fine way before i installed this faulty device. As a disabled Veteran i don't have that type of money to buy a new battery i told them. They didn't care at all. After a few weeks i got the money to get the new battery and 2 weeks later my battery was dead again. Yes i started my car because i drive it alot. My mechanic friend came out and told me that my electrical system was fried and had to get it towed. I was like wow! I called intoxlock and told them the problem and they said it was my car not their equipment. I was heated!!! My car got impounded because of tickets and now intoxlock want me to pay for it. I told them where the car was and they wrote down the wrong number of the tow yard and now they blaming me for it being destroyed. Wow Just wow!

    2 Votes
  • Ju
    Justin Hill87 May 06, 2019
    This comment was posted by
    a verified customer
    Verified customer

    I am having the same issue when I got my intoxalock installed on my 99 Honda Accord in Phoenix, AZ. The previous owner did not have no check engine light on or have problems with the transmission shifting. When the machine glitches. My check engine light goes off and the transmission shifts perfect. Also when they have recalibrated the machine my car runs perfect. The installer tells me it is my car. But, I have replaced so many parts on my car that it is not funny. I am a mechanic and keep my car very well maintained. I just dont know what to do.

    0 Votes
  • El
    Elizabeth Grafer Aug 21, 2019
    This comment was posted by
    a verified customer
    Verified customer

    Similar issues with my vehicle...had to replace alternator, then spark plugs, coils, fuel injectors, still intermittent cylinder misfires, now having PCM replaced...have spent thousands on repairs in the last two months since having the device installed, on a car with less than 40, 000 miles on it! Authorized installer charged me $135 to “insure” me it had nothing to do with the device. Dealership where I’ve been having my vehicle serviced says there not really sure if it could be the device itself, or something went wrong with the initial installation ...either way, Intoxalock is not taking responsibility for any of it! Furious!

    0 Votes
  • Ow
    owlly Sep 24, 2019
    This comment was posted by
    a verified customer
    Verified customer

    Has anyone had brake problems ?My car was trying to stop while I was accelerating. I pulled over and there was smoke coming from the wheel. My car was towed to the "brake mechanic" and he couldn't find anything wrong and said my car drove fine for him.

    0 Votes
  • Ch
    Chucks805 Nov 06, 2019
    This comment was posted by
    a verified customer
    Verified customer

    My car started to rumble and shake after getting the IID installed. Did a tune up in my car. Change spark plugs and all that. Still had check engine light on. The mechanic told me the IID might be causing the engine to misfired.
    2010 Dodge Charger

    0 Votes
  • Gc
    G Cross Jun 11, 2020
    This comment was posted by
    a verified customer
    Verified customer

    Not long after having my interlock device installed, my truck’s turn signals started acting up. After awhile they only worked occasionally. Towards the end of my year with the device my check engine light and service engine soon light started coming on. Occasionally during that period my engine would get sluggish. Also, my rpm and speedometer would start “dancing”. The other day, just before my year was up, my truck wouldn’t start even though it accepted my breath sample. I had to get it towed ($350) and then the next day when the device could get removed (because the mechanics couldn’t figure out how to blow), I had to get a mobile company to come there to remove the device (an extra $100 because not many mobile companies available). After that the truck started right up. Unfortunately, the 2 warning lights came back on after I left the mechanic’s shop. Obviously something was screwed up by having the device- period.

    0 Votes

Post your comment