Honda Rancher 350 Eschoke cable is not working!

P
This review was posted by
a verified customer
Verified customer

I have a Honda rancher 350 es, choke cable has not worked for 3 years have to reach under seat to prime carb, i was told by the dealer that cable was a bad design, unit has very low hours, cable must have gotten water in around boot, i was told new replacement was a much better design unit is not used but once in while,but it sure would be nice to have a choke cable that worked, seeing as how it went bad through no fault of my own, dealer never told me not to get unit wet, unit is an 02 model but is used very little for problems like this.

Responses

  • To
    Tom Barr Oct 23, 2007
    This comment was posted by
    a verified customer
    Verified customer

    I Have a 2000 Honda 350Es I had the same problem with mine I bought a new cable & used a reassembly grease it is still working great the new design is a lot better then the old one!

    0 Votes
  • Ro
    ronald durfey Jan 03, 2008
    This comment was posted by
    a verified customer
    Verified customer

    My atv gets very little use and I have incountered the same problem this season. It runs very good however on those cold days it sure would be good to have the choke working properly. I am suprised there has not been a recall on the matter.

    0 Votes
  • Ti
    Tim Batterson Sep 26, 2008
    This comment was posted by
    a verified customer
    Verified customer

    I have two Ranchers and both choke cables have broke. I want to replace them but I can't find them on line. I would like to avoid the cost of the dealer.

    0 Votes
  • Bu
    buzzard Nov 27, 2008
    This comment was posted by
    a verified customer
    Verified customer

    youre talking $8 for a cable...you want cheaper than that??

    0 Votes
  • Ro
    Robert Mar 19, 2009
    This comment was posted by
    a verified customer
    Verified customer

    I have an '01 350 ES and choke cable broke. I used to pull off the air filter and choke it by hand, and that worked great. I recently had it at the dealer getting various problems fixed and had them fix the cable while they were at it. Now the choke works, starts and runs good until it gets warmed up. After its warm it hardly runs unless the choke is on. What's up with that.

    0 Votes

Post your comment

    By clicking Submit you are agreeing to the Complaints Board’s Terms and Conditions