Explore your opportunities! Create an account or Sign In
The most trusted and popular consumer complaints website

MIO Technologies / Awful experience

United States Review updated:
5
Contact information:

In 1/2008 purchased a MIO C230 GPS device.From day 1 it started throwing an error an rebooting itself. Contacted manufacturer's support, was told to do a hard reset, then to reinstall software and ultimately to send it to them to reflush it. Returned the device to me after the flushing, still same problem. Called them again (their customer support is in India), the person I spoke with told me again to do a hard reset, reflush and the whole 9 yards they told me before.

I told her I already did all these steps and even sent it to their lab to be checked.Then she said this is 'normal operation' - the fact that every 10-15 minutes it throws a fatal error and then reboots itself and there is nothing she or anyone else in the company can do for me.
Va
0

Comments

Sort by: UpDate | Rating
Mi
  18th of Nov, 2008
Agree Disagree 0 Votes
i to have a c230 and the map software will not load. im going through hell calling the Filipino operators that can barely speak English and do not know what the hell they are doing. they cant even understand a simple question. i went through hell trying to get my device repaired and i get emails saying its not under warranty when i sent them the proof of purchase with the damaged device! I hate calling the operators on the phone they all sound like they are reading the manual in front of them.
Kb
  1st of Mar, 2009
Agree Disagree 0 Votes
I had a MIO for five months and the screen cracked after I left it in my car overnight. Apparently from cold weather. MIO refused to honor the warranty claiming the GPS was mishandled. I paid $240 for this piece of junk. Our friends at MIO graciously offered to repair it for $80. I'd much rather use a dependable map.
Ti
  17th of Jun, 2009
Agree Disagree 0 Votes
Sometimes, you get lucky. I bought my Mio C230 used. At first, I thought it might possibly be bad battery because it stopped working after about 2 minutes. Upon recharging it fully, it worked like a charm. From getting me to my destination to allowing software modifications, it worked flawlessly! You just got unlucky with your device. I think that a certain percentage of manufactured devices are flawed. You just have to return it for a replacement product. Get the same model and hand in your non-working unit.

Post your comment

Submit
     

Reply to

close
Send