Explore your opportunities! Create an account or Sign In
The most trusted and popular consumer complaints website

CPU Micromart / Bad service

0% 1
Contact information:
CPU Micromart
I ordered my ION PC from their site, www.thelinuxstore.com, on 05July1999 and they charged my Visa on 08July1999. They did not ship the PC until 20July1999. This is a big NO-NO. Visa rules require that they do not charge a card until they ship the product.
The excuse I was given by Randy was they were swamped with orders and wanted to make sure the PC worked before shipping. When it arrived ~27July1999, it had several problems:
1. The power connector to the motherboard was not completely seated and would not turn on.
2. The modem was misconfigured for COM4 and IRQ5 - DOH!!
3. The mouse I received was a generic serial mouse and the PC was configured for a PS/2 mouse.
4. There was a maintenance CD left in the CD-ROM drive.
5. I paid extra for 128Meg of memory but only 64Meg was installed.
6. The LPT port on the motherboard was not working.
7. I had to reconfigure the on-board sound everytime I rebooted the machine - and the MPU-401 settings never did work.

I called for a replacement motherboard and was given an RMA to return the defective motherboard when I received it. It never came.
I called to followup in the 2nd week of August and found out that the replacement was never shipped. After going through 3 layers of customer service (which is difficult to get in touch with anyway) I finally got a replacement on order and shipped.
When the replacement arrived a week later, it did not have functioning video. The company did issue a call tag to pick it up, but since I was moving to a new residence, I asked them to hold off shipping the next replacement until the 6th of September.
The 2nd replacement hadn't been shipped. I followed up with Tiffany SEVERAL times. I was told that they were on backorder. I was told that they were testing them. For a period of 4 weeks I did not receive ANY word back. I called Tiffany in the first week of November and finally a replacement was shipped on 10November1999.

When I received the replacement, I knew off the bat that they really were feeding me a line previously. I had been told that the reason for the delays was that they were testing their motherboards. Considering that the Anti-static packaging was intact from the OEM, there was no way that CPU/Micromart tested it.
The 2nd replacement (3rd motherboard) had 2 problems:
1. Would not recognize network cards because the onboard network was not disabled - there was no connector to connect the included IF card nor any jumper to disable it.
2. Would not recognize the onboard sound - I could have disabled it, but I paid for a board with sound.

I finally had enough. I called for an RMA number. I was told on Monday, 22November1999, that Glen Scheiler was assigned to get me an RMA. As of 23November, I still have no RMA.

This company has the worst customer service I have ever experienced.

Post your Comment


Reply to