The most trusted and popular consumer complaints website
Explore your opportunities! Create an account or Sign In

B&E Automotive / Terrible company

1 United States

I contracted with B&E Automotive to replace the worn out engine in my Ford Ranger pickup with a new engine, which I had ordered from the local AutoZone. However, they called me when the job was done, to tell me 'the overdrive (transmission) no longer works.' The transmission was new, with about 5k miles, and working fine before the engine replacement. Further, after paying the bill in full and returning home with my truck, I noticed that the engine temperature gauge no longer worked (again, was working fine, when they received the vehicle).

After returning the vehicle to their shop, I was called and told 'we fixed the temp gauge, but your truck has another problem - it quits after ~15 minutes and won;t restart. We will run diagnostics and call you back.' When they called back, I was told, 'we had to replace the electronic modules on the distributor - additional cost ~$300.00.' I did NOT authorize the additional repair. Finally, I discovered one more system that no longer worked: the cruise control.

After returning the trcuk once again, I was called and told 'You need a cruise control amplifier, which is a 'hard-to-find' part - you may be able to find one on the internet.' To which I replied, 'Did you check the local Ford dealer or aftermarket parts stores?' Their reply was 'No.' I went to pick up the vehicle and was charged another ~$70 for the diagnostic on the cruise control.

If I had known that BEFORE they touched my truck, I would have to SHOW THEM, 'See, the transmission works fine, the temperature gauge qworks fine, the cruise control works fine ...etc' - I would have gone SOMEWHERE ELSE!

Sa

Post your comment