The most trusted and popular consumer complaints website
Explore your opportunities! Create an account or Sign In

Advance 3W telecom firewall 2.0.0 / not compatible with vista

1 4 Horsley Hse, St. Norbert Rd., Brockley, SE4 2LGLondon, England, Greater London, United Kingdom Review updated:
Contact information:
Phone: 07737133265

advance 3w telecom firewall 2.0.0 is not compatible with my system that runs vista and I have already paid for the product,
please could I have a refund and the poduct removed from my system as it is of no use to me.
Thank you.

Sort by: UpDate | Rating

Comments

Ge
  10th of May, 2009
Agree Disagree 0 Votes

advance 3w telecom firewall 2.0.0 is not compatible with my system that runs vista and I have already paid for the product,
please could I have a refund and the poduct removed from my system as it is of no use to me.
Thank you...

Post your comment

     

Reply to

close
Send